VxRail Network DNS Yapısı ve Kurulumu -1.Bölüm

Merhabalar,
Günümüzde artık hyper converged (tümleşik yapı) yapısını çokça duyar olmaya başladık. Biz de firma olarak bölgede çözüm sağladığımız iş ortaklarımıza gerçek kurulum ve demolar yaparak hyper converged yapıyı anlatmaya başladık. Bugün sizlere dilimin döndüğü kadar Vxrail 3 node’lu yapının, Network ve DNS yapısı hakkında bilgi vermeye çalışacağım ve iki bölümden oluşan makalemin diğeri ise VxRAİL kurulumu hakkında olacak. VxRail network yapısı gereği VLANa ihtiyaç duymaktadır. Yapıyı devreye almadan önce yönetilebilir switch üzerinde (vMotion-vSAN) VLAN’ı kurulumu gerekmektedir. Biz 2 adet switch kullanarak VLT yapısı oluşturduk. Komut CLI satırlarını daha sonra paylaşacağım. Kullandığımız switchler DELL EMC ailesine ait olup yapıyı bu marka üzerine inşa edeceğiz. Switch modeli aşağıdaki fotoğrafta görülmektedir. Bu switchler yoğun veri trafiğinin yaşandığı Veri Merkezlerinde kullanılmaya başlanmış olup LEAF switch olarak da adlandırılmaktadırlar.

DNS YAPISI

DNS yapısına gelince;
Ortam da mutlaka DNS sunucu ihtiyacı vardır. Aşağıda paylaşılan resim üzerinde görüldüğü gibi A Kayıtlarının oluşturulması ve IP adreslerinin ona göre verilmesi gerekmektedir. Burada dikkat edilmesi gereken bir nokta olarak şunu aktarmak faydalı olabilir, IP sıralaması yönetim açısından önemli, resimdeki gibi IP sıralaması yapılması tavsiye edilmektedir.

Bu fotoğrafı da size örnek olması açısından paylaştım. Trafik 4×10 GB üzerinden olmaktadır.

VTP yapısı aşağıdaki resimde görüldüğü üzere bu şekilde olup ona göre switch konfigürasyonu yapılmıştır.

Aşağıdaki bölümde, fiziki switch yapısını ve fiziki bağlantıyı anlatan şema yer almaktadır. Her bir host için 2×10 gb lik port bağlantısı kullanılmıştır. Şema üzerinde görüldüğü gibi 10.11.ve 12 portları Vxrail network için, 1.2.3.ve 4 portları VLT için, 13.14 portları da uplink için kullanılmaktadır.

Komut CLI Satırları hostname EVANT-LEAF-1
!
lldp enable
!
spanning-tree mode rstp
spanning-tree rstp priority 0
!
interface mgmt 1/1/1
no ip address dhcp
ip address 192.168.1.1/24
no shutdown
!

interface vlan 101
description Management
ip address 192.168.10.1/24
no shutdown
!
interface vlan 102
description vSAN
no shutdown
!
interface vlan 103
description vMotion
no shutdown
!

interface vlan 3939
description pvtMgmt
no shutdown
!
interface ethernet1/1/1
description “VLT to EVANT-LEAF-2 1/1/1”
no switchport
no shutdown
!
interface ethernet1/1/2
description “VLT to EVANT-LEAF-2 1/1/2”
no switchport
no shutdown
!

interface ethernet1/1/3
description “VLT to EVANT-LEAF-2 1/1/3”
no switchport
no shutdown
!
interface ethernet1/1/4
description “VLT to EVANT-LEAF-2 1/1/4”
no switchport
no shutdown
! interface ethernet1/1/5
no shutdown
! interface ethernet1/1/6
no shutdown
!
interface ethernet1/1/7
no shutdown
!
interface ethernet1/1/8
no shutdown
!
interface ethernet1/1/9
no shutdown
!

interface ethernet1/1/10
description “Node-3_eth0-NDC1-10G-1”
no switchport
switchport mode trunk
switchport access vlan 101
switchport trunk allowed vlan 102,103,3939
spanning-tree port type edge
mtu 9216
flowcontrol transmit on
flowcontrol receive on
no shutdown
!

interface ethernet1/1/11
description “Node-2_eth0-NDC1-10G-1”
no switchport
switchport mode trunk
switchport access vlan 101
switchport trunk allowed vlan 102,103,3939
spanning-tree port type edge
mtu 9216
flowcontrol transmit on
flowcontrol receive on
no shutdown
!

interface ethernet1/1/12
description “Node-1_eth0-NDC1-10G-1”
no switchport
switchport mode trunk
switchport access vlan 101
switchport trunk allowed vlan 102,103,3939
spanning-tree port type edge
mtu 9216
flowcontrol transmit on
flowcontrol receive on
no shutdown
!

interface ethernet1/1/13
description “Uplink”
switchport mode trunk
switchport trunk allowed vlan 101
mtu 9216
no shutdown
!
interface ethernet1/1/14
description “Uplink”
switchport mode trunk
switchport trunk allowed vlan 101
mtu 9216
no shutdown
!

interface ethernet1/1/15
no shutdown
!
vlt-domain 127
backup destination 192.168.1.2
discovery-interface ethernet1/1/1
discovery-interface ethernet1/1/2
discovery-interface ethernet1/1/3
discovery-interface ethernet1/1/4
!

management route 0.0.0.0/0 192.168.1.1
!
uplink-state-group 1
name ESX-vSwitch-failover
enable
downstream ethernet1/1/10
downstream ethernet1/1/11
downstream ethernet1/1/12
upstream ethernet1/1/13
upstream ethernet1/1/14
upstream VLTi

hostname EVANT-LEAF-2
!
lldp enable
!
spanning-tree mode rstp
spanning-tree rstp priority 4096
!
interface mgmt 1/1/1
no ip address dhcp
ip address 192.168.1.2/24
no shutdown
!

interface vlan 101
description Management
ip address 192.168.10.2/24
no shutdown
!
interface vlan 102
description vSAN
no shutdown
!

interface vlan 103
description vMotion
no shutdown
!
interface vlan 3939
description pvtMgmt
no shutdown
!

interface ethernet1/1/1
description “VLT to EVANT-LEAF-1 1/1/1”
no switchport
no shutdown
!
interface ethernet1/1/2
description “VLT to EVANT-LEAF-1 1/1/2”
no switchport
no shutdown
!

interface ethernet1/1/3
description “VLT to EVANT-LEAF-1 1/1/3”
no switchport
no shutdown
!
interface ethernet1/1/4
description “VLT to EVANT-LEAF-1 1/1/4”
no switchport
no shutdown
!

interface ethernet1/1/5
no shutdown
!
interface ethernet1/1/6
no shutdown
!
interface ethernet1/1/7
no shutdown
!
interface ethernet1/1/8
no shutdown
!

interface ethernet1/1/9
no shutdown
!
interface ethernet1/1/10
description “Node-3_eth1-NDC1-10G-2”
no switchport
switchport mode trunk
switchport access vlan 101
switchport trunk allowed vlan 102,103,3939
spanning-tree port type edge
mtu 9216
flowcontrol transmit on
flowcontrol receive on
no shutdown
!

interface ethernet1/1/11
description “Node-2_eth1-NDC1-10G-2”
no switchport
switchport mode trunk
switchport access vlan 101
switchport trunk allowed vlan 102,103,3939
spanning-tree port type edge
mtu 9216
flowcontrol transmit on
flowcontrol receive on
no shutdown
!
interface ethernet1/1/12
description “Node-1_eth1-NDC1-10G-2”
no switchport
switchport mode trunk
switchport access vlan 101
switchport trunk allowed vlan 102,103,3939
spanning-tree port type edge
mtu 9216
flowcontrol transmit on
flowcontrol receive on
no shutdown
!

interface ethernet1/1/13
description “Uplink”
switchport mode trunk
switchport trunk allowed vlan 101
mtu 9216
no shutdown
!
interface ethernet1/1/14
description “Uplink”
switchport mode trunk
switchport trunk allowed vlan 101
mtu 9216
no shutdown
!

interface ethernet1/1/15
no shutdown
!
vlt-domain 127
backup destination 192.168.1.1
discovery-interface ethernet1/1/1
discovery-interface ethernet1/1/2
discovery-interface ethernet1/1/3
discovery-interface ethernet1/1/4
!

management route 0.0.0.0/0 192.168.1.1
!
uplink-state-group 1
name ESX-vSwitch-failover
enable
downstream ethernet1/1/10
downstream ethernet1/1/11
downstream ethernet1/1/12
upstream ethernet1/1/13
upstream ethernet1/1/14
upstream VLTi
!
Süleyman YURT
Sistem-Network Uzmanı
Evant Teknoloji – Adana, 2019